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INYAE Optimetrics: Example

* The Shorted Probe-Fed Patch Antenna with Optimetrics

This example is intended to show users how to set up a parametric study, optimize, and simulate the Analytic derivatives of a probe
feed patch antenna using the ANSYS HFSS Environment

A parametric sweep will be used to determine the effect on the input impedance match as a function of the feed pin position
This parametric sweep will be used to seed an optimization analysis that will be used to find the optimal position for the feed pin
Analytic derivatives will also be used to perform real time tuning of several dimensions of the patch antenna
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IVl ANSYS HFSS: Getting Started

* Launching ANSYS Electronics Desktop 2015

®* To access ANSYS Electronics Desktop, click the Microsoft Start button,
— Select Programs > ANSYS Electromagnetics > ANSYS Electromagnetics Suite 16.0. Select ANSYS Electronics Desktop 2015

* Setting Tool Options
* Note: In order to follow the steps outlined in this example, verify that the following tool options are set:
* Select the menu item Tools > Options > HFSS Options...
— Click the General tab
e Use Wizards for data input when creating new boundaries: ¥ Checked
e Duplicate boundaries/mesh operations with geometry: M Checked
— Click the OK button
* Select the menu item Tools > Options > 3D Modeler Options....
— Click the Operation tab
¢ Select last command on object select: M Checked
— Click the Display tab
* Set default transparency to 0.7
— Click the Drawing tab
* Edit properties of new primitives: M Checked
— Click the OK button
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WSSl Open Project

* Opening a Project
® Inthe ANSYS Electronics Desktop, select the menu item File > Open
— Browse to the folder containing the file Optimetrics_Patch_Training.aedt and select Open

£
4

4 © 2015 ANSYS, Inc. May 6, 2015 Release 2015.0



INYSN'Al Design Variables

* Checking Design Variables

* Two design variables have been created that control the location of the feed of the patch antenna, feed_pos, and the length of the
patch, patch_length

* Toview a list of any design variables that have been created for this design:
— Go to the menu item HFSS > Design Properties

* Alternatively, click on HFSSModell in the Project Manger Window, the design variables will be displayed in the Properties
Window

— Verify that the variable feed_pos is assigned the value 11 mm
— Verify that the variable patch_length is assigned the value 41.6mm
— Press the OK button

Properties: Optimetrics_Patch_Training - HF55Designl @
Local Variables |
& Value " Optimization ™ Tuning " Sensitivity ™ Statistics Patch Iength
Name | Value | Linit I Evaluated Value Type Description I Read-only | Hidden I Sweep I
feed_pos 1 mm 11mm Design - - ra
patch_length (416 mm 41.6mm Design - - ra
: [¥ Show Hidden
Add.. Add Aray.. Edi.. Femove |
—— feed_pos
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IV Parametric Analysis Setup

Parametric Sweep of Feed Position

We will now complete the creation of the parametric project using the defined variable to vary the coaxial feed position in order to
achieve optimal match between the patch antenna and its coaxial feed line. The ratio of the coaxial feed inner and outer diameters
was chosen to achieve a 50 Ohm characteristic impedance. So we will effectively change the value of the feed offset until we find a
position which presents a 50 Ohm load impedance on the coaxial feed line. The S11 vs. frequency plot has a dip at the patch
resonant frequency, the dip is maximized when the optimal offset is found.

Create Parametric Sweep

Select the menu item HFSS > Optimetrics Analysis > Add Parametric...
— Click the Add... button in the Setup Sweep Analysis window

* Inthe Add/Edit Sweep window: " i
Add/Edit Sweep ==

— Select the variable feed_pos

— Select Linear Step Vol |f p J Yariahle Dezcription |
arable  |feed_pos -
— Start: 9mm feed_pos Linear Step from Smnm ta 12mm, step=Tmm
— Stop:12mm " Single value
—  Step: 1lmm * Linear step —
. i L
—  Click the Add>> button Linear ount
. " Decad b
— Click the OK button -~ Frads con
. Detave count
— Click the OK button _
(" Exponertial count
Start: |9 |mm j 4
Shop: |12 |mm ﬂ
Shep: |1 |mm ﬂ

k. | Cancel
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ISl Analysis Configuration

* High Performance Computing Configuration

Parametric sweeps can be accelerated by solving multiple variations in
parallel. The HPC Analysis Configuration will allow us to specify the number
of cores and the number of tasks we would like to run. The number of tasks
will correspond to the number of parametric variations or frequency points
to runin parallel.

e Configuring HPC Settings

From the Analysis Options Toolbar, select Local configuration
Click the Edit Active Analysis Configuration button
Analysis Options Toolbar

§|Lcu:al ud 1B BB

Selected Analysi$ Configuration Edit Active Analysis Configuration

In the Analysis Configuation window, change the following:
— Uncheck Use Automatic Settings

— Tasks: 2

— Cores: 4

— RAM Limit(%): 80

Click the OK button to finish and close configuration window

* Analyze Parametric Sweep

In the Project Manager window, select Optimetrics > ParametricSetupl
right click and select Analyze
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5| Analysis Configuration @

Configuration name: | Local

I [ Use Automatic Settings I

Machines | Job Distabution | Options |
Machines for Distributed Analysis
Total Enabled Tasks: 2 Total Enabled Cores: 4

Name § Tasks | Cores | RAM Limit (%) | Enabled |
localhost |2 4 80 [vw

Ik

Machine Details:

(% Local machine

" IP Address format: 192.168.1.2): |

" DMS Mame format: www server.com): |

" UNC Mame format: “\server): |

Import Machines from File... Add Machine to List

oK | Cancel

Note: Additional machines can be added to the
configuration to further accelerate solutions. Each
machine can be used to solve 1 or more task. If an
analysis does not contain a parametric sweep, the
solution will distribute frequency points if a frequency
sweep has been specified.
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WVl Create Reports

* Create S-Parameter plot
— Solution: Setupl:Sweepl
— Domain: Sweep
— Inthe Trace tab
* (Category: S Parameter
* Quantity: S(P1,P1)
* Function: dB
—  Click the Families tab

Select the menu item HFSS > Results > Create Modal Solution Data Report > Rectangular Plot

* Make sure the Value for variable feed_pos is selected to All

— Click New Report button
* Click Close button

| Report: Optimetrics_Patch_Training - HFSSDesignl - Mew Report - New Trace(s) IEI &l Report: Optimetrics_Patch_Training - HF55Designl - Mew Report - New Trace(s) @
Context Trace | Familizs ] Families Display] Context Trace Families | Families Displa',']
Solution: + S Solution: + 5w
i Setupl: Sweepl ~ Primary Sweep: |Freq j |AII J outen Setupl: Sweepl hd Families : 4 available
Domain: ’—L| Bt '—L| * Sweeps (" Available variations
omain Sweep X [ Default |F|'e-:| J omain Sweep
|\z'ariable | Value | Edit |
Range
¥ |E|B(5(Plrp )] Function... eredjos All 4
Category: Quantity: = Function:
Variables - <none -
Qutput Variables ang_deg
ang_rad
' Parameter = arg =
Z Parameter b cang_deg
VSWR cang_rad
Gamma
Port Zo dB 10normalize
Lambda dB20normalize
Update Report ; = Update Report
Epsilon dBe MNominals: |patch_|engﬁ1 ﬂ
[ Real time Group Delay i Clalla ¥ Real time
Output Variables... | Options... | Mew Report | | Close Output Variables... | Options. .. | MNew Report | | | Close
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IVl Results
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ISl Optimization Analysis Setup

e Optimization

* The Parametric Sweep was useful for generating design curves. For this simple design with only a single variable we could use the
design curves to make educated guesses at performance targets that are not contained in the Parametric Sweep. To demonstrate
this we will target a minimum of less than -20dB for S;; at 1.8GHz for this shorted patch antenna. From the Parametric Sweep
results, we can see that the minimum return loss at 1.8 GHz will be achieved when the variable feed_pos is around 11mm.

* Create an Optimization Setup
* Select the menu item HFSS > Design Properties

— Click the Optimization radio button: Properties: Optiretrics_Patch_Training - HF55Designl @

* Name: feed_pos

Local Varables |
e Include: ¥ Checked

. " Value {* Dptimization " Tuning (" Sensitivity (" Statistics
*  Min:10 mm
* Max: 12 mm Mame | Include | Mominal Value Min | it | Mz | it |
— Click the OK button feed_pos [+  |[11mm 10 mm 12 mm
patch_length [ 41.6mm 208 mmm 624 mm

v Show Hidden
Add.. Add Aray... | r

oK | Cancel Apply

e Add Optimization Setup

* Select the menu item HFSS > Optimetrics Analysis > Add Optimization...
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ISl Optimization Analysis Setup

11

Setup Optimization
* Inthe Goals tab:
— Optimizer: Pattern Search(Search-based)
— Click the Setup Calculations... button
* Inthe Add/Edit Calculation dialog:
— Report Type: Modal Solution Data
— Solution: Setupl: Sweepl
— Domain: Sweep
— Category: S Parameter
— Quantity: S(P1,P1)
— Function: dB
— Click the Add Calculation button
— Click the Done button

¢ Click the Edit button

Click the value under Calc. Range and select Edit...

Setup Optimization @
Goals | Variables l General ] Optionz |
Optimizer: |F'attem Search{Search-based) hd
Mz, No. of terstions: IW
Cost Function:
Solution | Calculation Calc. Range | Condition | Goal | Weight
Setupl : Sweepl dB{S(P1,P1)) Freg(1.8GHz) €= [-20] [1]

I Setup Calculatiuns...l |

Acceptable Cost: |0 Moise: (0.0001 [ Show Advanced Cption

HPC and Analysis Options. . |

B

QK | Cancel

¢ Click the Select values radio button and select 1.8GHz

* Click OK button
Condition: <=

Goal =-20
Weight=1

® Click the Variables tab:

— Select View All Columns in lower right corner: M Checked

— Set Min Step value: 0.01
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Setup Optimization

'GoalsGeneml ] Options |

(=35

Variable | Cwvemde | Starting Value | Units | Include | Min | Units | e | Units§ Min Step | Units | Max Step | Units
feed_pos [v 11 mm [v 10 mm |12 mm J0.01 mm D9 mm
Set Foeed Variables... | Linear Constraint... | [v View All Columns

oK | Cancel
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INYAl Optimization Analysis Setup

' Goals ] ‘-fariables Options |

Parametrics Analysis: |Pa|ametric:Setup‘l ﬂ

* Setup Optimization (continued)
* C(lick the General tab:
— Parametric Analysis: ParametricSetupl

{ Solve the parametric sweep before optimization
(" Solve the parametric sweep during optimization
* This parametric analysis that we solved earlier will be used

. . Iv Update design parameters’ value after optimization
to seed the optimization

* Click the OK button to complete the optimization setup

* Analyze Optimization

Setup Optimization @

Cancel
* Inthe Project Manager window, select Optimetrics >
OptimizationSetupl, right click and select Analyze 7 Post Analysis Display =
| OptimizationSetup 1 | Qf Options...
e Optimetrics Results Resut | Profie |
* Right-click on OptimizationSetupl and select View Analysis Result View: (& Table
" Plat
— In the Result tab, select the radio button for Table
) o . . Evaluatinn| feed_pu:us| Cost | Expart...
— Click the Close button when you are finished viewing the ] 11708
results 2 10mm  B3602
3 Tmm 10633
4 T2mm 66,376
Optimal solution occurs at ~10.55mm, depending on the 5 1.8mm | 57.945 Q
points chosen by the optimizer, other values of feed_pos B 101mm | 015708
may satisfy the optimization criteria i 10.55mm |0

Close ‘
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I\NS I S Res u Its KX Report: Optimetrics_Patch_Training - HFSSDesignl - Mew Report - New Trace(s) @
Context "Trace Families | Families Displayl
Solutin: |SEb-'|31 i Sweepl j Families : 1 available
Domain: " - {* Sweeps { Available variations
* Create Reports omain: [sweep =l
Variable Value Edit |
* Select the menu item HFSS > Results > Create Modal EERCE feed_pos|10.55mm [ ] - e atvaises B
Solution Data Report > Rectangular Plot & select values
— Solution: Setup1:Sweep1l smm
10, Imm

— Domain: Sweep

— Inthe Trace tab Update Repart

« Category: S Parameter ¥ Real tme Nominls: | patch length -
* Quantity:S(P1,P1) e =y e e =l
*  Function: dB — Sweep: @ pefault =
—  Click the Families tab
 Click the Edit button 000 XY Plot 2 HFSSDesign1 4
— Click 10.55mm in the pop-up window |
— Close the pop-up window by clicking the X i Carve Info
button =007 e
—  Click New Report button feed_pos=10.Somm
— Click Close button -10.00

-30.00 T T T T T T T T T T T T T T T T T T T | T T T T
5 . . 1.90 2.00
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INYS'SE Analytic Derivatives

* Analytical Derivatives

From the parametric sweep and optimization of the feed position we can see that the optimal position is at about 10.55mm. To
further investigate or an alternative to the optimization, we could use analytical derivatives to predict the behavior of our model
with respect to small changes in design variables.

* Enable Analytic Derivatives

* Right click on Setupl in Project Manager Window and select Properties...
— Select Derivatives Tab
+ feed_pos: Use M Checked
e patch_length: Use M Checked
— Click the OK button
Driven Solution Setup @
Generl ] Options ] Advanced ] Expression Cache Dervatives | Defaults |
Produce Dervatives for these varables
Mame | Use
feed_pos [w
patch_length [v
QK | Cancel
* Analyze
[ ]

14

Select the menu item HFSS > Analyze All
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Project Manager

E--lm Optimetrics_Patch_Training
£}-## HFSSDesign1 (DrivenModal)

.g, 3D Components
..... & Model

[-EF Boundaries
B8} Excitations

..... BE Mesh Operations

-4 Analysis
W gsetup1]

[]..@ Optimetrics Copy Ctrl+C
#-[F] Results Paste Ctrl+V
&[] Port Field Dis -

..... ﬁ Field Overlay Rename F2
[]...? Radiation | 3 Delete oz

-[Z] Definitions
I Properties...
Disable Setup

Add Frequency Sweep...
Add Dependent Solve Setup...

Analyze
Revert to Initial Mesh
Apply Mesh Operations

Clear Linked Data

Create Quick Report...
Perform FFT on Report ...
Perform TDR on Report ...

Profile...
Convergence...
Matrix Data
Mesh Statistics...

Network Data Explorer...
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INYS'AE Creating a Tuning Plot

* Create Nominal Plot for Comparison
* Select the menu item HFSS > Results > Create Modal Solution Data Report> Rectangular Plot

Solution: Setupl: Sweepl

Domain: Sweep

Derivative: <none>

In the Trace tab

* (Category: S Parameter

* Quantity: S(P1,P1)

* Function: dB

Click the Families tab

* Click the Edit button
— Click 10.55mm in the pop-up window
— Close the pop-up window by

clicking the X button
Click the New Report button

* Continued on Next Page

15
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EY Report: Optimetrics_Patch_Training - HFSSDesignl - New Report - New Trace(s)
Context Trace | Families ] Families Display]
Solution: Setupl @ Sweenl -
| Pt P J Primary Sweep: |Freq j |A||
Domain: Sw
| weep ﬂ X v Default |F|'e-:|
Derivative: |<none:= ﬂ Ran
. SAnGE
¥ |dB|:SI:P1'P 1) Function. ..
Categaory: Quantity: =~ Function:
g Variables POl S(F1,P1) <none -
Qutput Variables ang_deqg
ang_rad
Y Parameter c arg =
Z Parameter 3 cang_deg
WVSWR cang_rad
Gamma
Port Zo dB 10narmalize
Lambda dB20normalize
Update Report Epsilon dEic -
v Be Group Delay - 4 |alig]

Llf_@

Qutput Variables. .. | Options... | Mew Report | | |

Close
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INYS'AE Creating a Tuning Plot

16

Create Tuning Plot

* Inthe Create Rectangular Plot Report, change the Derivative option

— Solution: Setupl: Sweepl
— Domain: Sweep

— Derivative: All

— Inthe Trace tab

* (Category: Tune S Parameter
* Quantity: Tune S(P1,P1,All)

¢ Function: dB
— Click the Add Trace button
— Click the Close button

© 2015 ANSYS, Inc.
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E Report: Optimetrics_Patch_Training - HF55Designl - XY Plot 3 - dB{S(P1,P1]))

Context

Solution:  |setp1 : Sweept =
Domain:  |Sweep =
Derivative: |Al =

[ |

Update Report

v Real time

Output Variables. .. ‘ Ogticuns...|

Trace | Families ] Families Display ]
Primary Sweep: |Freq j |.-5.|| J
Wi v Default |F|'Eq J
Range
¥: |dB(Tunes (P 1,P1,AI)) S
Category: Quantity: bl Function:
Variables Tune5(P1,P1Al) <none -
Cutput Variables ang_deg
ang_rad
Tune ¥ Parameter arg =
Tune Z Parameter cang_deg
Tune Gamma cang_rad
Tune Port Zo
Design dB 10normalize
dE20normalize
dBc e
o[ | »

Mew Repu:urt| Apply Trace | 5ddTrau:E|

Close
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INYS'AE Tuning Plot

e Tuning Plot

* Select the menu item HFSS > Results > Tune Reports ...

Move the scroll bars in the Report Tuning window to predict the performance for various patch width and feed position values

* Click the Close button XY Plot 3 HFSSDesignt 4
0.00
b Curve Info
] N - -~ dB(S(P1.P1))
-5.00 * Setup1 : Sweep1
i LY feed_pos="10.55mm’
| —— dB(TuneS(P1,P1,A1})
Setup1 : Sweep1
b feed_pos="10.56mm’
10,00 | Report Tuning &3
B Offsets
1 ﬂ ﬂ Apply offsets to
i feed_pos patch_length nominal design
i 10.55mm 41.6mm B ——— 1
—-15.00 — 1
> i | 1035 |4' 16 Save all offsets L
_ - - = || = L
i |
i Close 1
20.00 “J T _ »a
J 1y
1y
4 | -0.189% | -0.5824 '
i ]
_ -1.055 416 : r
[ ]
-25.00 < iy
1 b
J [
-30.00 T T T T T T T T T T T T T T T T T T T T T T T T
1.50 1.60 170 1.80 1.90 2.00
Freq [GHz]

Note: The predicted response is based off the nominal solution and partial derivative that was computed during the solution process.

Analytic Derivatives could have been used before any optimization to more quickly narrow the solution space by testing how
individual parameters will affect the antenna performance.
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