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Board Station Tutorial 
Written by Theodore Zeeff 

University of Missouri-Rolla 
Last Modified: April 5, 1998. 

 

Purpose: 

This tutorial describes how to design and manufacture a Printed Circuit Board (PCB) 
using Mentor Graphics.  

 
 

Board Station consists of 5 distinct programs 
 
?  Design Architect (DA)  
?  Librarian  
?  Package  
?  Layout  
?  Fablink 

The first of such programs, Design Architect (DA) will allow the user to conceptually 
draw out the design on the computer. Using circuit components such as basic logic 
elements, wires, buses, discrete components, etc., the design will quickly take form. Once 
completed, the design should look like one typically used by engineers for fine tuning and 
redesign.  

To take this design information and make it into an actual circuit, you will need to specify 
every detail about the PCB and any part that goes on it. The program you will use to 
describe these properties is Librarian. Once all of this information is provided and saved, 
the design can then be taken to the next stage of development. 

The next step uses Package. This program takes all of the information given by it in 
Design Architect and LIbrarian and links the two together. It also double checks 
anything you made yourself (parts, references to those parts...). Any errors made in the 
previous two steps will be found inside Package.  

The next step involves Layout. This program takes the information generated in previous 
steps and lets the user layout out the PCB with it. Final construction of the PCB takes 
place here, and by the end of this program every detail about the board will have been 
specified. 

After Layout, the desired PCB can be processed by Fablink. In Fablink , the design will 
be translated into a language the milling machines can interpret. These files can then be 
uploaded to the machine for fabrication. 
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Tutorial Sections: 

?  Begin Tutorial: Getting Started (UMR) (Part 1/7)  
?  How to use: BOLD BROWSER (Part 2/7)  

Designing a PCB using Board Station: 

?  How to use: DESIGN ARCHITECT (Part 3/7)  
?  How to use: LIBRARIAN (Part 4/7)  
?  How to use: PACKAGE (Part 5/7)  
?  How to use: LAYOUT (Part 6/7)  
?  How to use: FABLINK (Part 7/7)  

 
?  Back to: EE Home page 
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Board Station Tutorial 
Part 3/7 

Design Architect 
 

Before you begin, make sure you are in the PCB directory and that 'sul' and 'swd' have 
been executed inside this directory.  
To begin Design Architect, type da & at the eeclcxx% prompt. It will take some time to 
load the program. After about 20 seconds several disclaimers will have appeared and a 
window will come up on the screen. The screen should look something like the picture at 
the link below. 

?  Picture of Design Architect  

 

 

To start a new design sheet, press F1 or you may press the RMB (with the mouse cursor 
inside the DA window) and select Open Sheet from the menu titled Session 
( RMB>Session>Open Sheet). 

Another window will appear titled 'Open Sheet'. For the component name, type in 
Design1 or another appropriate name where $USERLIB was. Then click on OK. This 
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schematic will then be placed in the working directory named PCB. All of the information 
pertaining to the design will now be placed inside the directory '/PCB/Design1'. The 
name you give your 'sheet' should reflect what your design is. This name will be used 
to launch other programs in Mentor Graphics, so make it a good one.  
 
After a few seconds, you will see four different sections in the DA window. 
?  The first and largest will be the Design Schematic area. This particular window has 
the title :" Schematic #1" then the working directory: "PCB | Design1". This is where the 
schematic will be constructed.  

?  The second, which is in the upper right corner, is the Active Symbol window. This 
window displays the active symbol and what it will look like once placed in the Design 
Schematic window. 

?  The third area is the Schematic Pallet window, which is located in the middle far 
right portion of the Design Architect window. A variety of menus will be displayed here 
depending on what you are doing in the Design Schematic window. 

?  The forth area, located in the lower right corner of the Design Architect window, is 
called the Context Window. This shows the area presently displayed on the Design 
Schematic window relative to the entire design. 
 
 
TIP:  
There are additional commands for each window which can be accessed by clicking on 
the right mouse button (RMB) in each area's display window. Sometimes they can be 
used to speed up your design time. You may want to take the time to familiarize yourself 
with these menus.  
 
Short Cuts: 
Before we begin constructing the schematic, there are several shortcuts you should 
familiarize yourself with. 
?  The first involves using the middle mouse button (MMB). To use these shortcuts, just 
hold down the MMB in the Design Schematic window and move the mouse accordingly. 
A few of these are: 

?  Enter: short stroke to right.  
?  ESC: short stroke to left  
?  Zoom OUT: stroke to upper right  
?  Zoom IN: stroke to lower left  
?  View All: stroke to upper left  
?  View Area: stroke to lower right  
?  Center About point: two quick MMB clicks at desired location  

?  Additional Help: stroke in shape of question mark  
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?  The second type of short cut uses the ones listed below the Design Schematic window. 
They are positioned in several different boxes, each representing a function key(F1,F2...) . 
The letters in the middle box represent SHIFT, CONTROL and ALT. To use a particular 
function hold down the appropriate 'shift', 'control' or 'alt' key and press a function key.  
 
 
 
 
 

Making the Circuit Schematic 

Currently there is only one reliable way of making a PCB at UMR, making each 
component by hand. One of the major disadvantages to doing this (aside from the extra 
work) is that the parts you make will not be fully simulated parts (although I believe it 
can be done...). There are Libraries of components available right now, but there are no 
geometry files that can be associated with them. Hopefully, by Fall Semester '98, there 
will be a complete set of simulation parts and associated geometries.  
 
Making Symbols Not Found in On line Libraries: 
The following is an example of a power connector. This part has two power connections.  

To create the symbol that will represent your connector go to the pallet and choose 
RMB>Display_Schematic_pallet. Now click on the dark box containing 'Session'. Now 
select Open Symbol from the new display. A dialogue window will appear. Fill the 
window as follows: 
 
Component Name: 2pin_pwr 
Options: NO 

Another window will appear that looks similar to the one being used for your design. The 
name of the window should contain 2pin_conn somewhere in the title. The finished 
symbol will look like the link below.  

?  2pin_pwr Symbol:  

 



 

 6 

 

Will begin construction of the symbol by drawing the basic outline of the symbol that will 
define its boundaries in DA. Select pallet>Symbol_Draw>Add_Polygon or 
Add_Polyline. Now move your mouse cursor over the drawing area and click the LMB 
where you want the corners of your design to be. (Keep in mind that pins can only be 
attached to the large grid points displayed on this screen, so draw accordingly. Also keep 
in mind that you must end up at the same point where you started or you'll get an extra 
line on your symbol if you choose 'Add_Polygon'). An exact replica of the part is not 
needed at this point. Just draw a basic outline of what need to distinguish it from other 
parts on the DA schematic. Double click on a spot on the symbol when you are done.  
Once the basic shape of the symbol has been made we need to add properties to it so that 
Package and Layout will be able to read it when needed. Make sure only the body of the 
symbol is selected and choose RMB>Properties>ADD>Add_Single_Property. Now 
click on REF in the window that appears. Now type in ' 2pin_pwr ' for the Property 
Value:. It is extremely important that the name of the property be exactly the same as the 
name of the symbol(keep in mind that it is case sensitive). Once you have filled in this 
information press 'ok'.  
While still having the symbol body selected, add another property using the same method. 
This time select COMP as the property and again use ' 2pin_pwr ' as the property value. 
This time, however, make the property hidden by selecting the 'hidden' option in the 
property window.  

Now we will add pins to the symbol. Select pallet>ADD_Pin. Fill out the window as 
follows: 
Pin Type: IN  
Pin Names: 1,2 

The pin type is not critical to this symbol. The only difference between IN and OUT is 
what will be displayed near the pin in the DA circuit. This has no impact on the way the 
pin is read by any program.  
The pin names should be written down if you were making a more complex symbol. The 
exact same names will be required by Librarian and a wrong name will lead to the pin, 
component and any trace attached to it not being read properly.  

Now that the pin names have been made, you need to place the pins on the symbol. Click 
'OK' on the 'Add_Pin' window. Now place the pins as necessary.  

If you want to move the Pin Names, go to Setup in the menu bar. Now choose 'select 
filter'. When the new window appears, click on Set All. Now select 'OK' Now move your 
mouse cursor over the Pin Name you want to move. Now hold down the RMB (Right 
Mouse Button) and move the mouse cursor over the Move [a-MMB] selection. Now 
release the RMB. You should now be able to move the name of the pin anywhere you 
want to. Move the mouse till the name is in its desired location and press the LMB once.  

Once you are done making the symbol you will need to check it. Select 
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Check>With_Defaults. If it checks out properly then select File>Save_Symbol. After 
this is done you can close the symbol window without losing the new symbol.  
 

To use the symbol in DA first click the LMB anywhere on the Design Schematic window. 
Now from the pallet choose pallet>Choose_symbol. From the list of directories 
displayed in the window choose 2pin_pwr. Click 'ok' to close the window. Now you 
should see your symbol in the Active Symbol window. Place the part where necessary.  

The other parts done as examples are the 6pin_res and the 16pin.  The symbols are shown 
at the links below.  

?  6pin_res Symbol:  

 

 

?  16pin Symbol:  
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Selection/Deselection: 

When you place parts in Mentor Graphics, the part just placed remains selected and active 
until you deselect it explicitly. If you have more than one part selected at a time, this may 
cause problems. For instance, if you want to delete a part that was placed wrong or didn't 
belong there and you press the 'del' key to delete that part while more than that part is 
selected, you will delete all active selected parts. To prevent this from happening, deselect 
the part by pressing 'F2' after the part has been placed. A quick way to find out how many 
parts are selected is located just below the main title bar. If you were to select the 74ls00 
chip to place in the Design window you might see:  
sel (+1) (w|dae) (Design1|schematic|sheet1)(74ls00|MG_STD.POS)() 
The number after 'sel' in the parentheses is the number of selected items. After pressing 
'F2' the number goes back to '0+'. 

To select a part click on the body of the symbol. When the part is selected it will turn 
white. If you did not select the part, it will remain purple. You may also want to select a 
number of parts in a certain area. To do this you can hold down the LMB (near the part) 
and move the mouse around until the 'rubber band' encloses part of the symbol. Double 
check your selection by noting the number of selections after the 'sel'. Notice how the 
ends of the pins near the purple diamonds can be selected too. For moving and deleting 
purposes you should not worry about this feature. Just click on the body of the symbol 
and edit as necessary. 

If you make a mistake, you can correct your last edit by selecting >Edit>Undo. 
 
Wires: 
After an appropriate number of logic symbols and misc. parts have been placed you will 
need to connect them with wires. To do so press 'F3' or select add wire from 
RMB>ADD>Wire: . A tool bar will appear at the bottom of the main window labeled 'add 
WI' (this will remain in place while you are making wires).  
Start a wire by going to an appropriate place on the design and clicking the LMB. Now 
move the cursor to where it needs to be connected and press the LMB again. You can 
'bend' the wire by pressing the LMB where appropriate. (If you need to branch the wire, 
simply continue connecting one branch and once completed, backtrack, with same wire, 
to the point where it needs to branch off). Keep in mind that you should try not to use two 
or more wires to make one circuit node. Just backtrack through one branch and split off 
where necessary. Once you have completed one node, use the MMB shortcut for 'enter' to 
complete the wiring. Don't forget to press 'F2' to deselect the wires. 

If for some reason you need to connect two wires into one, select the pieces of wire that 
need to be connected, then use the command RMB>Connections>connect_all. Your 
wires are now connected. Remember,good wiring technique and consistent checking will 
keep you out of trouble later on. See the Checking Sheet section below for details on 
checking. 
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Adding Text to Design Schematic: 
You may want to add comments to the schematic from time to time to clarify the design. 
To add such comments you need to select "text" on the schematic pallet on the right hand 
side of the screen, then "add comment" in the menu. Next a tool bar will appear with the 
label 'text'. Simply type your comment, press enter and move the text accordingly. 
If you desire to change the height of the text then you need to change the selection filter 
so it can be selected. Go to Schematic>text>set_selection_filter and activate the 
comment text. Now select the text region with the LMB then press 
RMB>Property/Text>Change_Height... . Notice that you can do more than just change 
the height. You can also Move, Delete and Change Values (what text is displayed). 
Choose 'height' to change size of text. Note that the default text size is .1875 inches. 
 
Simplifying Designs: 
Globals: 
Sometimes you will want to connect to wires, planes, or components together without 
having to connect them on the schematic with wires. In such a case, you will want to add 
a global bus to your schematic. Adding a global bus to your design will allow you to save 
time and effort into making your schematic look nice and possibly make your design 
easier to read.  
To make a global bus, choose Libraries>MGC_Libraries. Now choose Connectivity 
Symbols from the palette menu. You will have to change the name of the global variable 
to get it to work properly. Two or more Global's with the same name will be connected, 
others will not be. Position your cursor over the 'G' near the global and press 'Shift+F7'. 
Type in the new name in the window provided.  
 
 
Checking Sheet and Saving:  
When your design is completed or you just want to save your design go to 
Check>Sheet>With_Defaults. The program will now check your design to see if you 
have made any serious mistakes. After it is done assessing your design, a comment 
window will appear. Inside the window will be displayed various accounts of the 
checking process. If any errors are present in your design, it will display them.  
If you select text in the 'Check Sheet' window and switch back to the 'Schematic' window, 
the area on the schematic that the high-lighted text was referencing will be selected. This 
can be useful when checking complicated designs.  
When you want to save the design, with or without errors, go to File>Save_sheet. When 
its done and you are ready to leave, click the RMB on the main DA window title bar and 
choose 'QUIT'.  

?  Next Part of Tutorial: Librarian  
?  Back to Main Page: Go to Beginning  
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Board Station Tutorial 
Part 4/7 

Librarian 
 

This part of the tutorial will center around building individual parts needed to make the 
entire PCB. Such parts as the board itself, a multi-pin connector, through holes, pad stacks, 
component geometries and company logos. The information here should give you a head 
start towards building any geometry required of you.  

 
 

To begin Librarian you must invoke it on your design. First make sure that the working 
directory is still the directory above your design directory by typing sul and swd in the 
PCB directory. Next type the following command: librarian Design1 (Use the same 
name you used when opening a sheet in Design Architect). 

Librarian should now load up on the computer. It will take around 20 seconds depending 
how fast the system server is working at the time. Once it has stopped loading you'll need 
to get rid of the report window by double clicking on the box in the upper left portion of 
the window.  

 
 

For most designs you will need to create a default pad stack geometry which will be used 
when no pad stack is defined for an object. After this is done you should make the board 
itself and then all other geometries you need. 

The following procedure details the process by which pad stack geometries are defined in 
Librarian. You may not need to make all three as listed (They are there for purpose of 
example) but you should make at least one through hole pin and one via so you have 
default geometries to fall back on in later steps.  
 

Creating Pin Pad stacks 
 

If you are using a part that doesn't come from the Board Process Libraries then you will 
need to create the part geometries and the geometry of the pad stacks that connect the part 
to the PCB. All of these geometries will then be stored in your account so that you will 
not need to build them again. 
 
 
Through hole Pin  
From the top menu select: Geometries>Create_Geometry> Thruhole_Pin...  
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Then fill in the dialog box that comes up as follows: 
 
Pin Name: t032rd 
Drill Size: .032 
Units: Inches 
 
No PAD Shape 
 
SIGNAL Shapes 
Layer: Signal 
Circle 
Diameter: .060 
 
POWER Shapes 
Layer: Power 
Circle 
Diameter: .070 
 
(Solder Mask)Single Shape 
Circle 
Diameter: .070 
 
No OTHER Shapes 
 
 
When you are done, press OK. A new window will appear in the Librarian session. 
Observe and verify that it is what you want. If you don't like what you see then just close 
the window and don't save. Otherwise continue making the rest of the geometries or save 
the geometry following the procedure below for saving pad stacks. 
 
The standard form for the name of the pad stack is as follows: 
t032rd  
t: This stands for through hole 
032 : This stands for the diameter (in inches *1000) of the drill hole 
rd : This stands for the basic shape of the pin, in this case, round. 
 
Standard Drill Sizes:  
.032  
.040  
.060  
.080  
.120  

Other drill sizes larger than .080 can be made, however, try not to use them if you can. 
They require more work to make when you get to the milling machine portion of PCB 
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creation. Surface Pin  
From the top menu select the following: Geometries>Create_Geometries>Surface_Pin 
 
Now fill in the box as follows: 
 
Pin Name: s70x30 
Units: Inches 
 
(Pad)Single Shape 
Rectangle 
Width: .070 Height: .030 
 
(Solder Mask) Single Shape 
Rectangle 
Width: .080 Height: .040 
 
No Paste_Mask Shapes 
 
No Other Shapes 
 
When you are done, press OK. Note that the name of the pad stack comes from what type 
of dimensions the object has.  
 
 
Through hole Via  
A through hole via is a type of pad stack that allows the milling machine to drill down to 
another layer on the PCB and connect to that lower layer. To create a via through hole 
choose the following from the top menu: 
Geometries>Create_Geometries>Thruhole_Via and fill in the window as follows... 
 
Via Name: v032rd 
Drill Size: .032 
Units: Inches 
 
No Pad Shape 
 
Signal Shapes 
Layer: Signal 
Circle 
Diameter: .050 
 
Power Shapes 
Layer: power 
Circle 
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Diameter: .060 
 
(Solder Mask)Single Shape 
Circle 
Diameter: .060 
 
No Other Shapes 
 

Saving Pad stacks 
 

To save the geometries you have just created choose the following from the top menus: 
File>Save>ASCII_Geometries... 
Then fill out the box in the following manner: 
 
Geometries to save: All Geometries (or Specific Geometries) 
Separate File for Each 
Library to Store the Geometry: Design 
Replace Existing File(s) 
 
After you have done this, a dialog box will appear and confirm your saving them. Now 
you are ready to quit Librarian if you need to by clicking the RMB on the main title 
screen and choosing 'quit'. It will then ask you if you want to save your work. Choose 
'yes' and if there are errors then you can still save if you need to.  
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Building a Board Geometry 
 

 

?  Picture of Completed Board with Logo  

 

 

 

To make a board geometry do the following from the top menus: 
Geometries>Create_Geometries>Board... Then fill out the dialog box as follows: 
 
Board Name: board (or some other appropriate name) 
 
Default pad stack Name: t032rd (or choose one you made above) 
Number of Routing Layers: 2 (or any number you wish) 
Default pad stack Size: .060 (may need to change depending on default) 
 
Route Power Nets: On Signal Layers 
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Click on 'OK' to close the box. 

Now you are ready to begin constructing the basic outline of the PCB. First zoom out 
using the shortcut keystrokes until the maximum vertical and maximum horizontal 
coordinates are above what you need for the dimensions of the board. Move the cursor 
around the screen to find out what they are. The coordinate system is below the main 
menu bar (use absolute coordinate numbers). 

Now you need to setup the grid to which the cursor will 'snap'. Go to Setup>Grid and 
type in .1 next to 'X Increment'. The 'y' increment will default to the 'x' increment if you 
don't specify it. In this same window go to the 'display interval' and type in 2. Now press 
'OK'. 

Start by selecting RMB>(TOP MENU)>SHAPES>Add_Polygon. Once you have done 
this you should see a cross hair where the cursor should be. Move the cursor to the 
absolute coordinate (0,0) and press the LMB. Now continue placing the four corners of 
the board geometry by clicking the LMB on the following locations: (4,0) (4,5) (0,5). 
Now double click on (0,0). You may want to make the board larger than you need it to be. 
The exact dimensions of the board can be specified later if needed. By doing so you make 
the layout of components easier to place in later steps.  

To complete the board you will need to specify where the routing can take place and 
where the components can be placed on it. Go to the menu 
RMB>Attributes>Create_Placement_Outline and choose interactive. 
You may want to change the grid so you can draw a more accurate outline. Once you are 
satisfied with the grid, place the cursor to the lower right hand corner of the board. Move 
out about .1 inches from each side of the board and press the LMB. Now place the 
corners of the board by clicking the LMB around the board in the appropriate places. Try 
to stay a uniform distance away from all sides. To complete the outline double click the 
LMB on on spot where the outline should be.  

Next you will make the routing outline. Typically this outline should be on the outside of 
the placement outline. Use RMB>Attributes>Create_Routing_Outline. Use a similar 
procedure for making this outline as was done for the placement outline. Try to keep the 
routing outline about .05 inches off of the board outline. 

If you want to add a logo to the board geometry then follow the procedure listed below, 
otherwise skip the next section and read on.  
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?  Picture of Logo  
 

 

 

 
Creating a Company Logo: 

 

The designs created in this section will be made out of copper and then placed on the 
board geometry. This section outlines a fairly basic procedure but should provide enough 
information towards making a more complicated logo.  

From the main menu choose Geometries>Create_Geometry>Generic.... A window 
should appear. Under 'Geometry Name:' type 'logo ' or some other appropriate name.  

The current editing layer should be the layer SIGNAL_1. The current layer is displayed in 
the upper right hand corner of the edit window. If it is not the current layer then select 
Setup>EditLayer then select Signal_1 (Physical _1) from the list. 
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Setup:  
You may want to change the width of the trace. To do this select setup>linewidth and 
select something higher than .01 inches. 

Next you should setup the Grid to which your cursor will snap. To accomplish this select 
from the main menu Setup>Grid. Set the "X Increment' to around .01 or .05 . Leave the 
'Y Increment' alone. Set the 'Display Interval' to 2. Press 'ok'. 

Next you will setup the line width of the traces. Select from the Main menu 
Setup>Line_Width. Enter .01 or more depending on your needs. Try to keep the size 
larger than .01. Press 'ok'. 
 
Text:  
To add text to the logo you'll first need to change the height of the text. Goto 
Setup>Text... from the main menu. In this dialogue box change the following...  
Height: .062 (or different value). 
Justification: Center Center 
Press 'ok'. 
Now select RMB>Text>Add_Interactive_Text:. Now place the mouse cursor where you 
want the text to start and press the LMB. Now type in the appropriate text and press enter.  

If you make a mistake or you just need to move part of the design around you will first 
need to setup the selection filter. From the main menu choose Setup>Select_Filter. Once 
the window appears select all of the entries you can select and click on 'ok'. Now you will 
be able to select any of the parts displayed on the edit window. If you need to move a part 
just select it with the LMB. Then click the RMB and choose the appropriate command. 
 
Drawing:  
To add lines to the design use the button on the Pallet window Addline>Vertices.. Select 
points around the drawing area where appropriate and make an outline of what you want. 

If you want to make a circle or polygon for your logo then choose 
RMB>Shapes>Add_Polygon or Add_Circle. 

As you may have noticed there are many different ways to construct a logo. Feel free to 
explore the other options included in librarian. Just keep in mind that all of the pieces on 
the logo should be made from the SIGNAL_1 layer if you want it on the top of the board 
and made from SIGNAL_2 layer if it is to be on the bottom layer.  
 
Adding Logo to Board Geometry. 
To add the finished logo to the board you already constructed you will first need to switch 
over to the edit window with the board geometry on it. You can 'shrink' the edit window 
size of the windows on top of the board geometry window until you see the board OR you 
can go to Geometries>Change_geometries and select the board from the list, select 'ok' 
on the window that appears next.  
Once you see the board geometry select 
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RMB>Shapes>Extended_Menu>Add_Geometry. Now fill in the box with the exact 
name of the logo you created. Don't change anything else in the window. Press 'ok'. Now 
move the cursor to where you want the logo to go. Press the LMB when you are over the 
right place.  

?  Picture of Completed Board with Logo  
 

 

 

 
Making Geometries for User Defined Symbols: 
Making your own symbols is a lot easier than you might think. In fact, its sometimes 
more convienient to make your own than it would be to search around the Board Process 
Libraries for the 'right' geometry.  
To make a component geometry, choose Geometries>Create_Geometries>Component 
from the top menu bar. In the window that appears, enter the name of your symbol under 
Component Name:. The exact name of the geometry is not critical. However, you may 
want to include soom information about the size or dimension of the part in its name so 
others like it don't get confused with the one you made. For instance, if the geometry you 
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are making is a surface mount capacitor, you may want to include the size of the pads in 
rests on. ie; smt_cap_20x20_mil.  
For the rest of the dialog box, choose a default padstack (t032rd, sm20, t060rd,...) and 
then choose what type of component it is (thruhole or surface mount). You may also want 
to change what type of units you will be using to describe your component (Metric or 
English).  
Once you press OK, another window will appear with the name of your component in the 
title bar. Zoom out to the appropriate level and change your grid spacing to something 
that makes sense for the type of component you're making.  
Now select RMB>Attributes>Add_Component_Body_Outline . Now use the LMB to 
set the corners of the component to the desired shape. Once you have set the last corner, 
double click on it to complete the outline.  
Now select RMB>Attributes>Add_Placement_Region>Both_Sides. Follow the same 
procedure to complete this outline.  
Now you will need to place pins on the component. Do so by selecting "comp" from the 
palette menu. Now click on ADD_Pin. A dialog box will appear at bottom of the 
component window. Inside this box there will be a number under the listing "NUMERIC". 
You may type in what ever number you choose. The number of the geometry's pin doesn't 
have to match that of the component used in Design Architect. Press 'Ok' and move the 
cursor to the desired location. You can continue adding pins in this fashion by continuing 
to press 'enter' after ever pin is placed.  
Once you have completed each of these steps then you can save the component by 
selecting File>Save_Design_All.  
Catalogs and Mapping Pins: 
Now that you have constructed the basic geometries of the symbols you made in Design 
Architect we are ready to associate the pin numbers used in Design Architect to the pins 
of the geometry in Librarian. This will allow traces to be connected to the parts when you 
enter Layout. If you make a mistake here in Librarian you may notice that some of the 
pins of your component don't connect properly in Layout. To avoid confusion later on, 
make sure you follow this procedure exactly and that you use the correct component 
names (case-sensitive!).  

First you will need to create a catalog where all of the mapping files will be placed. The 
default active catalog is your 'current design' catalog and could be used for this process. 
However, using a separate catalog other than your design catalog will allow you to use 
these files in other designs and not just this one.  
To create a catalog select: Catalogs>Create_Catalog:. A tool bar should appear at the 
bottom of the screen. Fill the window out as follows: 
Name: (Your_Catalog_Name) 
In Directory: USER (select by pressing up/down arrows) 

Now we will make sure that the active catalog is the catalog you have just created. (As 
you build more and more designs on your account this may provide useful.) Select 
Catalogs>List_Active_Catalog . Now click on Catalog Hierarchy. Now click on 
USER. Now verify that the active==> icon is beside the catalog you want. If it is not then 
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click the LMB on the line which has the name of your catalog. Once you have selected 
the proper catalog press Close.  
Now we are ready to create part numbers for the physical geometries we have just created. 
These files will allow traces to be routed to the parts used in your design. If you do not 
need traces routed to a particular part then you can skip this step without ruining your 
design.  
To create a part number select Catalogs>Create_Part_Number. If you are following the 
IEEE-SEE project then fill out the window as follows: 
 
Part Number: PN-6pin_res 
Catalog Name: (should already be there) 
Geometry: 6pin_res (make sure this is the exact name) 
Mapping: (leave blank) 
 
Replace Part: Yes 

Two windows should now be displayed on the screen. The one on the left is the mapping 
window and the one of the right is the geometry window.  

?  Picture of Completed Mapping File of 6pin_res  
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In the left window select RMB>Map_Logic_Symbol.... Now fill out the window as 
follows: 
 
Comp Property 
 
Property Value: 6pin_res (use exact name) 
 
Map Symbol Count: 1 
 
Map Symbol Name: 6pin_res (name not critical) 
Now we are ready to add logic pins. You could also add power pins if you wanted to, 
however, this is typically used for designs that have dedicated power and ground planes. 
To add logic pins select in the left window RMB>Add_Logic_Pins. Now fill out the 
window as follows: 
 
Create Pin Name: 1 
Swap Code: 1 
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Create Pin Name: 2 
Swap Code: 1 
 
Create Pin Name: 3 
Swap Code: 3 
 
Create Pin Name: 4 
Swap Code: 3 
 
Create Pin Name: 5 
Swap Code: 5 
 
Create Pin Name: 6 
Swap Code: 5 

After you have completed this window you should see a list of all the logic pins you have 
just made. The swap codes to the right of the pin name indicates which pins can be 
swapped by the auto-router used in Layout to save unnessary routing. Two pins with the 
same swap code can be switched with each other. The swap number is completely 
arbitrary except that they are not zero. A swap code of zero means that the pin shouldn't 
be switched with anything. 
Now we are ready to associate the pins in the left window with the pins in the geometry 
window. Select from the left window RMB>Map_Pins:. Now click on a pin in the left 
window and then click on its corresponding pin in the right window. Continue clicking 
until all pins have been matched up.  

Now check your part number by selecting Check>Part_Number>Active_Part_Number. 
Get rid of the report window and fix any errors if present. Once your part number is 
correct, save the design by selecting File>Save>Design_All. 

For the IEEE-SEE project the following part numbers and mapping files were created. 
?  Mapping File of 9pin_res  
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?  Mapping File of 2pin_pwr  
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?  Mapping File of 16pin  
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Saving Geometries and Saving Design: 

 
Now you will need to create a backup of your work. Do so by going to 
File>Save>ASCII_Geometries...  
 
Fill the dialogue box out like this... 
Geometries to save: All Geometries (or Specific Geometries) 
Separate File for Each 
Library to Store the Geometry: Design 
Replace Existing File(s) 
 

To save the work on the design go to File>Save>Design 
 
After a few messages appear and confirm the save, you can leave librarian. You are now 
ready to use Package.  

 
?  Next Part of Tutorial: Package  
?  Back to Main Page: Go to Beginning  
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Board Station Tutorial 
Part 5/7 

Package 
 

 
The purpose of this section of the tutorial is to run Package, a program which collects all 
of the information from Design Architect and Librarian and organizes them into a format 
which can be easily read by the next two programs of the tutorial, Layout and Fablink.  
First you will read in all of the geometries you have made, then Package will organize all 
of the information.  

 
To run Package first make sure that the working directory is the one which contains the 
directory of your design. If you are following this tutorial exactly, then that would be the 
PCB directory. Type 'sul' and 'swd' once inside this directory. 

Execute the program on your design by typing: package Design1 . The program will load 
and a series of warning messages that you should ignore. It may take a few minutes to 
load. 

After the messages are gone get rid of any report windows. The screen should look 
something like the link below.  

?  Picture of Package  
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To the far right of the screen there should be a button labeled 'Active Catalogs'. Click on 
this button. You may need to expand the size of the Package window. Just go to the 
extreme lower left corner of the window and use the LMB to expand the window size.  

You should see a large beige dialogue window on the screen. At the bottom of the screen 
you should see a small box next to the words 'Catalog Hierarchy'. Click on this box.  
Now you should see a list of all of the catalogs currently on the system. Go to 'Design 
Catalogs' and click with the LMB. 
Now you should see the ACTIVE => design Status: UNREAD. Click on 'READ', which 
is in the lower left hand side of the window. After you are done, 'Close' this window.  

Now that the geometries you created are loaded onto the system you will need to combine 
them with the ones already there. Go to the right side of the screen and click on the button 
named 'Update'. Use the default values that appear in the window that comes up. After 
the program is complete you should see more information listed on the screen than you 
had before. This information includes the part numbers, mapping files and the geometries 
of the parts used.  
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Now you are ready for the next step of the design process. Go to the top menu and choose 
Save>Design_All. Save it with Back Annotate and view point. Once completed, exit 
Package.  

 
?  Next Part of Tutorial: Layout  
?  Back to Main Page: Go to Beginning  
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Board Station Tutorial 
Part 6/7 

Layout 
 

The purpose of this program is to construct the PCB into its final form.  
 

 

As was done before, make sure that the working directory is set to the one that has the 
directory of your design in it. Use 'sul' and 'swd' once in this directory.  

Execute the program on your design by typing: layout Design1 . Once the program is 
loaded clear the report window. Ignore any 'warnings' you encounter in the report window, 
they will be resolved later. If you get any 'errors' then you have done something wrong 
and will need to backtrack to previous steps.  

A picture of the board should appear on the screen. In order to view everything on the 
board select View>Layers from the top menu. Now select All_visible in the window that 
appears. Close the window.  

 
Placing Components: 

 
Now you will place all of the components on the board. Select 
RMB>Auto_Placement>Place_Components. Keep all of the default values except 
make sure that the will be placed on the 'top only'. Press 'ok' once you are done and like 
the settings in the window. The program will now place all of the parts according to what 
it feels is the smallest configuration of components. When the program is done you 
should see all of the components used in your design on the board. You may have noticed 
that this program does a poor job of placing components. To move the parts where they 
should be go to Setup>Select_Filter and choose components only. Now click on a 
component and use RMB>Move or RMB>Rotate to get the parts to a desirable location. 
If you violate any placement rules(putting one part atop another) then it will return the 
part its last location.  
Once you are satisfied with the location of the parts you are then ready to set down some 
design rules and begin routing.  

 
Creating Routing, Layer, Net and Grid Rules. 

 
To create routing rules select Setup_Routing>Routing_Rules. Fill out the dialogue box 
as follows: 
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Trace Grid X: .005 Y: .005 
Pin Grid X: 0 Y: 0 
Via Grid X: 0 Y: 0 
 
T-Junctions Allowed 
 
Diagonals Allowed 
Trace Vertex Bends: Orthogonal and Diagonal 
Pad and Via Entry: Orthogonal and Diagonal 
 
Route Connections By: Length 
 

Setting Up Net Rules: 
 
Before you take this design to the next level a few design parameters will need to be put 
in place. These rules will govern how Layout and Fablink will place components and rout 
traces.  
To setup these rules choose from the main menu Setup_Routing>Change>Net_Rules.... 
Now choose Create_New_Net_Type and then make DEFAULT_NET_TYPE the name. 
Now choose Setup rules... Now fill in the categories like this... 
 
Trace Width .012 
Pin to Pin Clearance: .013 
Via to Via Clearance: .013 
 
Pin to Trace Clearance: .013 
Via to Trace Clearance: .013 
 
Pin to Via Clearance: .013 
Trace to Trace Clearance: .013 
 
 
For Interactive Routing Vias: v050rd 
For Interactive Routing Vias for Auto Routing: v050rd 
 
Available Routing Layers: Physical_1 and Physical_2  
(Choose both by holding down CTRL button and click once on each selection) 

If you need to alter the grid to which the router will adhere to then select 
RMB>Auto_Routing>Change_Routing_Grid>Change_Routing_Grid.... Fill out the 
window to your specifications. If you change your mind then select 
RMB>Auto_Routing>Change_Routing_Grid>Reset_to_Design_Rules.... 
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To change the Layer rules select the following: Setup_Routing>Layer_Rules.... Make 
sure that Physical_1 (top layer) is disabled for the meantime and that the preferred 
direction of Physical_2 (the bottom layer) is set to 'ALL'. This done so that the majority 
of the traces will be on the side that is most easily soldered.  
After all of the traces that can be made have been, the physical_1 layer should be 
reactivated. This will cut down on the number of vias used to make the circuit board ($$$).  
 

 
Routing Traces: 

Once you are confident that the rules meet your requirements and that the parts are in 
their best location then you are ready to begin the Auto-Routing process. 
Begin by selecting RMB>Auto_Routing>Start_Auto router. Fill out the window as 
listed below.  
 
Breakout 
Number of Passes: 1 
Automatic 
Number of Passes: 5 
Pattern 
Number of Passes: 5 
Manufacturing 
Number of Passes: 5 
The rest of the window should be left at the default values. Click on 'ok' once you are 
done.  
 

Once this program is run you should see displayed a scrolling report displayed across the 
screen. At the end of the report note the number of unroutes. A running total is displayed 
above the scrolling window (you may find it easier to read). If there are some unroutes 
then you may need to run the Auto-Router again. If this is the case then you may want to 
delete all of the traces it has made by first changing the selection filter at 
Setup>Select_Filter by selecting only traces. You don't necessarily have to delete all of 
them either. Then you need to select all traces on the board and press delete. Now you can 
either use the same defaults for the traces as you used above or you may want to reduce 
the trace width and use no grid for traces. Repeat as necessary.  
 
When all of the traces have been routed close the report window and verify that the traces 
have been made. If the are there then you are ready for the final stage in the design 
process, Fablink. 
 

 
?  Next Part of Tutorial: Fablink  
?  Back to Main Page: Go to Beginning  
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Board Station Tutorial 
Part 8/8 

Fablink 
 

The purpose of this program is to make information files that can be used with the routing 
machine in ERL. To accomplish this task several files will be made. (One for all of the 
drill holes, one for the milling data, and one for the every trace layer used. There will also 
be a few report files made for you reference.) All of these files will be automatically 
placed in the /pcb/MFG directory of your design.  

 
 

To enter Fablink type this at the command prompt: fablink Design1 
After Fablink has loaded close any report windows and ignore any warnings about test 
points.  

 

Drilling Data 

To create the drilling data first select 
RMB>Drill>Change_Drill_Table>Fill_Drill_Table. Don't change any of the values in 
the window and press 'ok'.  

Now we will create the drill data and verify that it looks correct. Select 
RMB>Drill>Create_Drill_Data . Now fill out the window with the values given below.  
 
Drill File Format: Excellon 
Generate for: Board 
Drill Character Set: ASCII 
Mirror: OFF 
Drill Hole Types: Both  
Output Hole Types: All Types 

A report window should now be displayed, close it to continue. 
 
To verify that the drill data worked properly choose: 
RMB>Drill>Simulate>Drill_Data... . You should see the drill holes and the path that the 
drill will take outlined in red. Close the window when you feel that this looks fine. If this 
doesn't look fine to you then maybe you made an error in librarian when you defined 
some components or maybe the drill table was filled out incorrectly.  
 
Now go to Report>Drill_Table and include drill format and save and display report.  
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Artwork Data (Traces and Logos) 
Now we will create artwork data that will represent every copper trace and every other 
shape made from copper. There will be one file created for every trace layer in your 
design.  

Begin by selecting RMB>Artwork>Change_Apeture_Table>Fill_Apeture_table 

Next go to RMB>Artwork>Change_Artwork_Format and set Plot_Offsets to Manual 
with (0,0).. 

Then choose RMB>Artwork>Create_Artwork_Data 
 
Fill out the dialogue window as follows: 
 
File Format: Gerber 
Character Set: ASCII 
 
Artwork Number: ALL 
Output All Pins, Vias 
 
Resize, Rescale Artwork: NO 

After filling this out go to RMB>Artwork>Simulate_Artwork_Data 
Choose the first one (Signal_1 or Physical_1). After this is done another window will 
appear on the screen. This window will display the top layer's traces and logos made from 
copper. Close the Artwork window once you are done looking at it.  
Now follow the same procedure but for the other layer(Signal_2 Physical_1).  

To let the milling machine operator know what type of tools to use, you will need to 
create a file that contains trace information. Go to Report>Aperture_Table and select... 
Include Artwork Format  
Save and Display Report 

 

Milling Data  

Now we will make the milling data needed for cutting the board outline. Make sure the 
small box in the upper right hand corner of the main edit window says 'milling' and not 
some other layer name. If it doesn't say 'milling' then change it by selecting 
>Setup>Change_Edit_layer> and then click on the name milling which is in the left 
column of names. Verify that the name 'milling' appears in the small window. If it doesn't 
the the program will not recognize the milling outline until you fix it.  
 
Begin by selecting RMB>Milling>Change_Tool. Select.. 
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Tool Diameter: .040 (or .080) 
Tool compensation: Right 
Plunge at : Absolute Location 
Digitize Point at: Absolute Location 

If you want to follow the outline of the board exactly then choose Nearest Vertex for 
'Plunge at' and 'Digitize Point'. For the IEEE-SEE project the final size of the board was 
unknown and therefore an exact board geometry was not made in Librarian.  

After closing this window select RMB>Milling>Start_Tool_Path. Now select a corner 
of the board where you want to start cutting and click the LMB. Now click on the corners 
of the board where you want it to be cut at. Be sure to go in a counter-clockwise direction. 
Once you have made it around the board cancel the tool bar or use the shortcut for escape.  

Now select RMB>Milling>Change_Milling_Table>Fill_Milling_Table 

Now select RMB>Milling>Create_Milling_Data. Keep the defaults in the window and 
press 'ok'.  

Now go to Report>Milling_Table and include milling format and Save & Display 
Report. Close the report window.  
 

 
You are now done with this portion of the design. Save and Back Annotate the design as 
you have done before. Close the Fablink window. All of your data files are now in the 
/pcb/mfg directory of your design. Next you will take the data files to the milling machine 
for board fabrication. See the milling operator for details.  

 
?  Back to Main Page: Go to Beginning  
 
 

 



 
专注于微波、射频、天线设计人才的培养 易迪拓培训 
网址：http://www.edatop.com  

 

射 频 和 天 线 设 计 培 训 课 程 推 荐 

 

易迪拓培训(www.edatop.com)由数名来自于研发第一线的资深工程师发起成立，致力并专注于微

波、射频、天线设计研发人才的培养；我们于 2006 年整合合并微波 EDA 网(www.mweda.com)，现

已发展成为国内最大的微波射频和天线设计人才培养基地，成功推出多套微波射频以及天线设计经典

培训课程和 ADS、HFSS 等专业软件使用培训课程，广受客户好评；并先后与人民邮电出版社、电子

工业出版社合作出版了多本专业图书，帮助数万名工程师提升了专业技术能力。客户遍布中兴通讯、

研通高频、埃威航电、国人通信等多家国内知名公司，以及台湾工业技术研究院、永业科技、全一电

子等多家台湾地区企业。 

易迪拓培训课程列表：http://www.edatop.com/peixun/rfe/129.html 

 

 

射频工程师养成培训课程套装 

该套装精选了射频专业基础培训课程、射频仿真设计培训课程和射频电

路测量培训课程三个类别共 30 门视频培训课程和 3 本图书教材；旨在

引领学员全面学习一个射频工程师需要熟悉、理解和掌握的专业知识和

研发设计能力。通过套装的学习，能够让学员完全达到和胜任一个合格

的射频工程师的要求… 

课程网址：http://www.edatop.com/peixun/rfe/110.html 

ADS 学习培训课程套装 

该套装是迄今国内最全面、最权威的 ADS 培训教程，共包含 10 门 ADS

学习培训课程。课程是由具有多年 ADS 使用经验的微波射频与通信系

统设计领域资深专家讲解，并多结合设计实例，由浅入深、详细而又

全面地讲解了 ADS 在微波射频电路设计、通信系统设计和电磁仿真设

计方面的内容。能让您在最短的时间内学会使用 ADS，迅速提升个人技

术能力，把 ADS 真正应用到实际研发工作中去，成为 ADS 设计专家...

课程网址： http://www.edatop.com/peixun/ads/13.html  

 

HFSS 学习培训课程套装 

该套课程套装包含了本站全部 HFSS 培训课程，是迄今国内最全面、最

专业的HFSS培训教程套装，可以帮助您从零开始，全面深入学习HFSS

的各项功能和在多个方面的工程应用。购买套装，更可超值赠送 3 个月

免费学习答疑，随时解答您学习过程中遇到的棘手问题，让您的 HFSS

学习更加轻松顺畅… 

课程网址：http://www.edatop.com/peixun/hfss/11.html 
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专注于微波、射频、天线设计人才的培养 易迪拓培训 
网址：http://www.edatop.com 

CST 学习培训课程套装 

该培训套装由易迪拓培训联合微波 EDA 网共同推出，是最全面、系统、

专业的 CST 微波工作室培训课程套装，所有课程都由经验丰富的专家授

课，视频教学，可以帮助您从零开始，全面系统地学习 CST 微波工作的

各项功能及其在微波射频、天线设计等领域的设计应用。且购买该套装，

还可超值赠送 3 个月免费学习答疑… 

课程网址：http://www.edatop.com/peixun/cst/24.html  

 

HFSS 天线设计培训课程套装 

套装包含 6 门视频课程和 1 本图书，课程从基础讲起，内容由浅入深，

理论介绍和实际操作讲解相结合，全面系统的讲解了 HFSS 天线设计的

全过程。是国内最全面、最专业的 HFSS 天线设计课程，可以帮助您快

速学习掌握如何使用 HFSS 设计天线，让天线设计不再难… 

课程网址：http://www.edatop.com/peixun/hfss/122.html 

13.56MHz NFC/RFID 线圈天线设计培训课程套装 

套装包含 4 门视频培训课程，培训将 13.56MHz 线圈天线设计原理和仿

真设计实践相结合，全面系统地讲解了 13.56MHz线圈天线的工作原理、

设计方法、设计考量以及使用 HFSS 和 CST 仿真分析线圈天线的具体

操作，同时还介绍了 13.56MHz 线圈天线匹配电路的设计和调试。通过

该套课程的学习，可以帮助您快速学习掌握 13.56MHz 线圈天线及其匹

配电路的原理、设计和调试… 

详情浏览：http://www.edatop.com/peixun/antenna/116.html 
 

我们的课程优势： 

※ 成立于 2004 年，10 多年丰富的行业经验， 

※ 一直致力并专注于微波射频和天线设计工程师的培养，更了解该行业对人才的要求 

※ 经验丰富的一线资深工程师讲授，结合实际工程案例，直观、实用、易学 

联系我们： 

※ 易迪拓培训官网：http://www.edatop.com 

※ 微波 EDA 网：http://www.mweda.com 

※ 官方淘宝店：http://shop36920890.taobao.com 
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